Subject: mail log

From: Joshua <[email-masked]>
Date: Wed, 5 Apr 1995 00:57:58 -0400 (EDT)

Hi,
  I am using procmail to do email autoreplies.

#### my .procmailrc ########

:0
* !^FROM_DAEMON
* !^From+YOUR_USERNAME
{  :0
   * [email-masked]
   | (formail -r -A"Precedence: junk" -I"Subject: file f1";\
    cat $HOME/outbound/f1.txt) | $SENDMAIL -t

   :0
   * [email-masked]
   | (formail -r -A"Precedence: junk" -I"Subject: file f2";\
    cat $HOME/outbound/f2.txt) | $SENDMAIL -t

   :0
   * [email-masked]
   | (formail -r -A"Precedence: junk" -I"Subject: file f3";\
    cat $HOME/outbound/f3.txt) | $SENDMAIL -t

   :0
   $HOME/outbound/.log
}
####### End of my .procmailrc #########

Procmail auto replies to file requests fine. However, all my regular mails
went into file .log without showing  up in my Pine Mailer or Unix
Mail Mailer. My intention for .log file is to record down all requesters'
email addresses. How can I acomplish that? Suggestions for other 
potential flaws in my .procmailrc and for improvement of my .procmailrc
are also welcome.
   Thank you in advance.
Joshua

---

From: Genealogy Online <[email-masked]>
Date: Fri, 7 Apr 1995 20:31:25 -0700 (PDT)

On Wed, 5 Apr 1995, Joshua wrote:

> email addresses. How can I acomplish that? 

	The above is "logging" everything that did not previously find a 
match.  You can put something like this at the top, which will log 
everything:

VERBOSE=off
LOGFILE=$HOME/outbound/.log

	I set up a separate account I call 'reply' to which I alias 
autoreply 'accounts.'  Personal mail goes elsewhere and, therefore, is 
not logged.

-Michael

--------------------------------------------------------------------------
 Michael Cooley                                         [email-masked]
 Genealogy Online                                [email-masked]
--------------------------------------------------------------------------