Subject: more than one command

From: [email-masked] (Oliver Wrede)
Date: Wed, 25 Jan 1995 16:15:22 +0100

Hi there,

I read the manual pages an I am quite confused ath the moment. Isn't it
possible to write a "newbie" version?

I have occured following problem. I simply want to have a mail stored in a
folder *AND* execute a program in which it should be piped into. Following
entry does only execute the first line (storing the mail in the labnews
folder":

:0:
* ^Subject: .*Lab:*
labnews
| /share/bin/hypermail -l "Lab News" -i -u -d "/wwwserver/labnews"

What is missing?

Oliver

-- 

 . oliver wrede  . . . . . . . . . . . . [email-masked] . 
 . academy of media arts . cologne . . . . . . . . . . . . . . . .
 . fb design of fh cologne . . . . . . . . .  (nextmail welcome) .
 . . . . . . . . . . . . . . http://www.khm.uni-koeln.de/~owrede .

---

From: [email-masked] (Robert W. Kerns)
Date: Wed, 25 Jan 1995 09:50:48 +0800

> | /share/bin/hypermail -l "Lab News" -i -u -d "/wwwserver/labnews"

Braces.

:0
* ^Subject: .*Lab:*
{
   :0:
   labnews

   :0
}

I don't know what /share/bin/hypermail does, so I don't know
whether it needs locking to avoid simultaneous delivery of two
messages.  If it does, it might look like this:

:0
* ^Subject: .*Lab:*
{
   :0:
   labnews

   :0:/wwserver/labnews.lock
   | /share/bin/hypermail -l "Lab News" -i -u -d "/wwwserver/labnews"
}

(And if for some reason you needed to keep the ordering in both
files the same, you could put a lock on the outer condition, but
that's unlikely to be useful).

By the way, I think I probably see another bug, in your
regular expression:

Probably you want:

*^Subject: .*Lab:.*

What you wrote allows any number of :'s, rather than what I
expect you want, "Lab:" followed by anything else.  Of course,
since you didn't specify anything after that, the final .*
doesn't do anything, so you could omit it.

---

From: [email-masked] (Robert W. Kerns)
Date: Thu, 26 Jan 1995 19:41:09 +0800

>  > | /share/bin/hypermail -l "Lab News" -i -u -d "/wwwserver/labnews"

And *I'm* missing the 'c' on the first delivery inside the braces!
Gack, and sorry!

 >    | /share/bin/hypermail -l "Lab News" -i -u -d "/wwwserver/labnews"

:0
* ^Subject: .*Lab:*
{
   :0 c:
   labnews

    :0

Similarly for the example below.