Subject: Re: forwarding some but not all?

From: [email-masked] (Stephen R. van den Berg)
Date: Wed, 29 Jun 1994 20:01:52 +0200

David W. Tamkin <[email-masked]> wrote:
>Stephen van den Berg suggested to Peter Stark,

>| What about:
>| 
>| 	:0 w
>| 	* ^From:.*ADDRESS2@
>| 	| formail -I "From: ADDRESS1@ (your name)" | $SENDMAIL -oi -t
>| 
>| 	:0 Ew
>| 	! ADDRESS2@
>| 
>| Or, if you have an older version of procmail (or if you find this more
>| readable):
>| 
>| 	:0 w
>| 	* ^From:.*ADDRESS2@
>| 	| formail -I "From: ADDRESS1@ (your name)" | $SENDMAIL -oi -t
>| 
>| 	:0 w
>| 	* !^From:.*ADDRESS2@
>| 	! ADDRESS2@

>Why do we need the 'E' flag or the opposite condition on the second recipe?

Perhaps because I forgot to mention the 'c' flag I had in mind on both
recipes :-).
As in:

 	:0 wc
 	* ^From:.*ADDRESS2@
 	| formail -I "From: ADDRESS1@ (your name)" | $SENDMAIL -oi -t
 
 	:0 Ewc
 	! ADDRESS2@

-- 
Sincerely,                                  [email-masked]
           Stephen R. van den Berg (AKA BuGless).

To boldly program, where *no* man has programmed before!

---

From: Quindel <[email-masked]>
Date: Wed, 29 Jun 1994 21:49:57 -0600 (MDT)

>  	| formail -I "From: ADDRESS1@ (your name)" | $SENDMAIL -oi -t
 Oh just great! Now I am really confused. Anyone have a good explanation?
Thanks.
QUindel
aka The one who asked the question