Subject: Re: procmail: Command not found?

From: [email-masked] (Stephen R. van den Berg)
Date: Mon, 20 Mar 1995 13:24:07 +0100

Zhiliang Hu <[email-masked]> wrote:
>>From [email-masked]  Sun Mar 19 17:42:22 1995
> Subject: get cal form and policy(for entire policy text)
>  Folder: /home/cal/bin/formail -r |(cat; cat $HOME/CAL/CAL.H-form    1268
>tabs: Command not found.
>tabs: Command not found.
>cat: formail: Command not found.
>Command not found.

>I wonder (1) did procmail (reply) work?  (2) why command 'cat' is not
>found?

The reply did not work.
Four things you should do:
- Set SHELL=/bin/sh at the top of your .procmailrc
- Set PATH to something reasonable.
- Verify that the formail binary is in /home/cal/bin.
- Check to see on which machine your .procmailrc is being executed (mailserver
  perhaps?).

-- 
Sincerely,                                  [email-masked]
           Stephen R. van den Berg (AKA BuGless).

The eleventh commandment: Thou shalt not re-curse!

---

From: Jon Lewis <[email-masked]>
Date: Mon, 20 Mar 1995 17:30:36 -0500 (EST)

> - Check to see on which machine your .procmailrc is being executed (mailserver

I was pulling my hair out all weekend trying to get the mail-fileserver 
example to work.  Adding the SHELL line above fixed it.  What shell does 
procmail use if the SHELL variable is not defined?  The default login 
shell of the user?  I thought I used syntax that would have worked in 
tcsh, but it didn't.

------------------------------------------------------------------
 Jon Lewis                     |  [email-masked]
                               |          
                               |  
 Mime attachments are OK       |           
 But please ask before sending unsolicited huge files.        
                                      
http://inorganic5.chem.ufl.edu  
_____Finger [email-masked] for PGP public key_____