Subject: generate leading From line

From: Joshua <[email-masked]>
Date: Thu, 13 Apr 1995 12:27:24 -0400 (EDT)

Hi,
   I am using procmail to do autoreplies. In some cases, the procmail
misread the leading "From field". Instead reply to the original sender,
it replies to the mail forwarder.
   Can any body offer some solutions? It will be better if I 
can solve this problem using .procmailrc.
   Many thanks.

Joshua

# my .procmailrc file

:0 h
* !^FROM_DAEMON
* !^From+YOUR_USERNAME

:0 hc
{
  from=`sed -n -e '/From:/s/From: //p' -e '/^$/q'`
  to=`sed -n -e '/To:/s/To: //p' -e '/^$/q'`
  date=`date +'%a %b %d %Y %T'`
  :0
  | echo $to $date $from >> $HOME/outbound/.log
}

:0 h
  * [email-masked]
  | (formail -r -A"Precedence: junk" -I"Subject: Info: Hyson Intl";\
    cat $HOME/hyson/info.txt) | $SENDMAIL -oi -t

---

From: Adam Shostack <[email-masked]>
Date: Thu, 13 Apr 1995 15:07:08 -0400 (EDT)

Use formail instead of sed scripts.  Parsing mail headers is not
obvious, but formail -r does a pretty good job.

Adam

|    I am using procmail to do autoreplies. In some cases, the procmail
| misread the leading "From field". Instead reply to the original sender,
| it replies to the mail forwarder.

-- 
"It is seldom that liberty of any kind is lost all at once."
						       -Hume