Subject: Re: Forwarding Question

From: Adam Shostack <[email-masked]>
Date: Fri, 30 Dec 94 12:31:47 EST

Peter Stark wrote:

| I would like to set my account to use procmail and forward mail. However 
| I already have procmail set up to do three other things.
| 
| What I am trying to do is set it up so that if I get anything from anyone
| that are not from three addresses to forward the mail. if it is from 
| three certain addresses to keep it here. Is that possible?
| 
| Would the following work:
| 
| :0 w
| * !person1@address1
| * !person2@address2
| * !person3@address3
| ! [email-masked]

	I don't think you need a w flag, and scanning for ^From:
person will be slightly faster.

| Would it run everything above it and then do this last, or is the order 
| equal and it would sort it out first and forward before the others? THe 
| above program is the last thing in the procmailrc file.

Procmail goes through your recipies file one line at a time.  The last
line in the file is parsed last.

Adam

-- 
"It is seldom that liberty of any kind is lost all at once."
						       -Hume

---

From: [email-masked] (Stephen R. van den Berg)
Date: Thu, 12 Jan 1995 21:01:52 +0100

>| ! [email-masked]

Even faster would be:

	:0
	* !(person1@address1|person2@address2|person3@address3)
	! [email-masked]

The parens are optional in this case.
The 'w' flag is recommended if you want to detect a failure to forward.

-- 
Sincerely,                                  [email-masked]
           Stephen R. van den Berg (AKA BuGless).

This is a day for firm decisions!  Or is it?