Subject: Re: Two mail spools?

From: "Michael J. Corrigan" <[email-masked]>
Date: Tue, 17 Jan 1995 22:20:10 -0800

Sure. A global procmailrc file with just

:0c:$LOGNAME
/oopsspool/$LOGNAME

and a 2nd copy will go into their mail spool also.

> Is there an easy way to use procmail as the sendmail local delivery
> agent and have it deliver messages to two different spool areas?  I'd
> like to do this to provide "oops" recovery.  If a user deletes a
> message by mistake and/or somehow gets a corrupted mailbox, a restore
> command could have some daemon copy the mailbox from the secondary
> spool area to the primary spool area.
> 
> My mail server doesn't know anything about users' home directories so
> it won't be using their rcfiles.
> 
> All suggestions appreciated.
> 
> 
> Thanks,
> Tom.III
> 
> ----------------------------------------------------------------
> Thomas Dwyer III                        Email:   [email-masked]
> Systems Programmer                      Voice:   (906) 487-2112
> Computing Technology Services           Fax:     (906) 487-2787
> Michigan Technological University       VHF/UHF: N8MHF
>

---

From: [email-masked] (Stephen R. van den Berg)
Date: Thu, 19 Jan 1995 20:51:31 +0100

Robert E. Landsparger <[email-masked]> wrote:
>> > Thus spake, Michael J. Corrigan:

>> > The man page shows to use "-d recipient" for local delivery in sendmail.
>> > Which then quotes:
>> > 	"...Procmail will  setuid  to the intended recipients and
>> > 	shall only read the recipient's .procmailrc file (if  present,
>> > 	if not, delivery is like ordinary mail)."

>sure enough.  I created a /etc/procmailrc and it worked.  Hmmm... maybe
>I read the man page wrong.  :)

Keeping man pages up to date has never been my favourite occupation,
seems like this sentence qualifies for an update :-).

P.S. You might want to use DROPPRIVS=yes before delivering the
     mail from within /etc/procmailrc

-- 
Sincerely,                                  [email-masked]
           Stephen R. van den Berg (AKA BuGless).

The eleventh commandment: Thou shalt not re-curse!