Subject: puzzled over this..

From: Robert Nicholson <[email-masked]>
Date: Thu, 5 Jan 1995 00:09:40 GMT

I have several rules in my .procmailrc that look like the following.

0 w:xemacs
* [email-masked]
|formail -I Newsgroups | mail2news xemacs

    :0 e:
    xemacs

Ever other rule appears to work fine. 

However, messages to this rule seem to be blocking.

Here's my mailq output.

--Q-ID-- --Size-- -----Q-Time----- ------------Sender/Recipient------------
XAA00622*       0 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>
XAA00723*       0 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>
XAA00731*       0 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>
XAA00884*     195 Wed Jan  4 23:29 <[email-masked]>
                                   <[email-masked]>
XAA00632*    1112 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>
XAA00653*    1189 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>
XAA00896*    1200 Wed Jan  4 23:29 <[email-masked]>
                                   <[email-masked]>
XAA00800*    1470 Wed Jan  4 23:29 <[email-masked]>
                                   <[email-masked]>
XAA00929*    2110 Wed Jan  4 23:29 <[email-masked]>
                                   <[email-masked]>
XAA00751*    2472 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>
XAA00680*    2583 Wed Jan  4 23:28 <[email-masked]>
                                   <[email-masked]>

Also here's the procmail log.

>From [email-masked]  Wed Jan  4 23:29:50 1995
 Subject: Error with calendar phases of moon...
  Folder:  echo $DATE $FROM $SUBJECT >/dev/console  

The rule that's matched is the following.

# alert to new messages to console.

    :0hc
    *
    | echo $DATE $FROM $SUBJECT >/dev/console

Every other message matches this rule correctly. Only xemacs messages
appear to have a problem. 

Here's a log entry...

>From [email-masked]  Wed Jan  4 23:30:29 1995
 Subject: consecutive select-screen/select-window bug [was: Bug(?) when same fi
  Folder:  echo $DATE $FROM $SUBJECT >/dev/console             1344

Here's the PS output as the moment...

 208 ?  S     0:06 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  224 ?  SW    0:04 /usr/lib/NextStep/Workspace.app/WM.app/WM -NXAutoLaunch YES -MachLaunch 1 28
  226 ?  S     3:43 /LocalApps/Emacs.app/Emacs -NXAutoLaunch YES -MachLaunch 6 33
  228 ?  S     0:03 /LocalApps/TickleServices1.11/TickleServices.app/TickleServer.daemon
  250 ?  SW    0:00  (sendmail)
  251 ?  S     0:05 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  277 ?  SW    0:00 sendmail: running queue: /usr/spool/mqueue
  278 ?  S     0:06 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  304 ?  S     0:00 /LocalApps/Emacs.app/lib/emacs/19.28/mab-next-nextstep3/wakeup 60
  308 ?  SW    0:00 sendmail: running queue: /usr/spool/mqueue
  309 ?  S     0:05 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  329 ?  SW    0:00 sendmail: running queue: /usr/spool/mqueue
  330 ?  S     0:05 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  633 ?  SW    0:00  (sendmail)
  634 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  635 ?  SW    0:00 sendmail: XAA00632 felix.dircon.co.uk [193.128.224.10]: DATA
  636 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  671 ?  SW    0:00 sendmail: XAA00653 felix.dircon.co.uk [193.128.224.10]: DATA
  672 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  705 ?  SW    0:00 sendmail: XAA00680 felix.dircon.co.uk [193.128.224.10]: DATA
  710 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  741 ?  SW    0:00 sendmail: XAA00723 felix.dircon.co.uk [193.128.224.10]: DATA
  746 ?  SW    0:00  (sendmail)
  749 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  755 ?  S     0:05 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  789 ?  SW    0:00 sendmail: XAA00751 felix.dircon.co.uk [193.128.224.10]: DATA
  794 ?  S     0:05 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  821 ?  SW    0:00 sendmail: XAA00800 felix.dircon.co.uk [193.128.224.10]: DATA
  822 ?  S     0:05 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  913 ?  SW    0:00 sendmail: XAA00884 felix.dircon.co.uk [193.128.224.10]: DATA
  914 ?  SW    0:00 sendmail: XAA00896 felix.dircon.co.uk [193.128.224.10]: DATA
  915 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  916 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert
  952 ?  SW    0:00 sendmail: XAA00929 felix.dircon.co.uk [193.128.224.10]: DATA
  956 ?  S     0:04 /usr/local/bin/procmail -f [email-masked] -a  -d robert

---

From: [email-masked] (David W. Tamkin)
Date: Thu, 5 Jan 1995 11:02:56 -0600 (CST)

Robert Nicholson wrote,

|     :0hc
|     *
|     | echo $DATE $FROM $SUBJECT >/dev/console

The sample message you gave had parentheses in its subject.  They might be
confusing the shell that procmail forks to run echo (">" is a SHELLMETA). 
Also, it helps to use the `i' flag when you're running a command that doesn't
read standard input; otherwise procmail wants to know why its writes aren't
accepted.

Try this so that characters special to the shell don't cause as much trouble:

      :0hci
      | echo "$DATE" "$FROM" "$SUBJECT" > /dev/console

As to why your forwarded mail on that subject isn't picked up by the re-
ceiving site, I don't know; that's outside procmail's purview and can have
any number of causes.

David W. Tamkin  Box 3284  Skokie, Illinois  60076-6284
[email-masked]    MCI Mail: 426-1818   +1 312 714 5610