Subject: Mail Setup with Procmail, HLFSD, & NFS

From: [email-masked] (Randy Bush)
Date: Tue, 7 Mar 95 05:57 PST

> Can Procmail delivery reliably over NFS?

No.  But no mail agent can.  It is a problem with NFS design.  Do not
write mail spools over NFS (either MTA or readers which delete).

When writing an file mounted over NFS, fsync(2) returns when the data are
in the writer's kernel buffer, and likely not yet on media.  Compare this
with the man page on fsync(2).

---

From: [email-masked] (Stephen R. van den Berg)
Date: Tue, 7 Mar 1995 17:39:57 +0100

>with the man page on fsync(2).

But procmail checks the returncode of close(2).  Close(2) will return
an error code even if NFS got in trouble.

-- 
Sincerely,                                  [email-masked]
           Stephen R. van den Berg (AKA BuGless).

This sentance contains threee errors.