Subject: Re: testing .procmailrc using formail

From: [email-masked] (John Conover)
Date: Thu, 19 Jan 95 14:45 PST

Richard Coleman writes:

 > When I add something to my .procmailrc, I would like
 > to test it.  Particuarly, if I add a new entry for a
 > mailing list.  How can I use formail to generate a
 > test message to myself that looks like it came from
 > a mailing list?

What I do is save the message, say in a file named "newmessage," and
use the following to send it to my account, "myname."

/usr/bin/rmail myname < newmessage

which runs the message back through the mail system.

	John

-- 

John Conover, 631 Lamont Ct., Campbell, CA., 95008, USA.
VOX 408.370.2688, FAX 408.379.9602
[email-masked]

---

From: "J. Daniel Smith" <[email-masked]>
Date: Thu, 19 Jan 95 20:34:37 -0500

John Conover ([email-masked]) writes on 19 January 1995 at 14:45 PST
> > [...]

What I've been finding myself doing lately is creating "test.rc" which
has the new stuff in it.  I set LOGFILE and DEFAULT to /dev/tty,
create a sample mail file and then
   procmail ./test.rc < test.mail

   Dan
----------------------- message is author's opinion only ----------------------
J. Daniel Smith <[email-masked]>                   http://www.bristol.com/~dan
Bristol Technology Inc.	                        +1 203 438 6969, 438-5013 (FAX)
Ridgefield, Connecticut (USA)                           {info,[email-masked]
                                --------
 Von guten Maechten wunderbar geboren, erwarten wir getrost, was kommen mag.
 Gott ist mit uns am Abend und am Morgen, und ganz gewiss an jedem neuen Tag.
	- Dietrich Bonhoeffer