Subject: bot without text rebound

From: Carl Reimann <[email-masked]>
Date: Mon, 3 Apr 95 20:15:27 EDT

Hi again. I use this bit of text for a low-use bot:

===============================

:0c:
*^Subject:.*text.*text
destination.file
  
 :Afh
 |formail -r -i "Subject: returned subject" -i "Reply-to: reimann@.digex.net"
 :A
 |(cat;cat directory/filepath) | $SENDMAIL -oi -t

===============================

The trouble is that their message to me is also returned.
How can I use this without returning their text?

Carl

---

From: [email-masked] (David W. Tamkin)
Date: Mon, 3 Apr 1995 21:55:35 -0500 (CDT)

Carl Reimann asked,

| Hi again. I use this bit of text for a low-use bot:
| 
| ===============================
| 
| :0c:
| *^Subject:.*text.*text
| destination.file
|   
|  :Afh
|  |formail -r -i "Subject: returned subject" -i "Reply-to: reimann@.digex.net"
|  :A
|  |(cat;cat directory/filepath) | $SENDMAIL -oi -t
| 
| ===============================
| 
| The trouble is that their message to me is also returned.
| How can I use this without returning their text?

Add an `h' flag to the last recipe (or, less efficiently, take it off the
second-to-last one).  Better yet, replace the last recipe with these two:

   :Afbi
   | cat directory/filepath
   :A
   ! -oi -t

I'd also recommend that you use "Reply-To:" with a capital T rather than
"Reply-to:", which causes trouble for certain mail programs.

David W. Tamkin  Box 3284  Skokie, Illinois  60076-6284
[email-masked]    MCI Mail: 426-1818   +1 312 714 5610