Subject: Returning Read Receipts

From: Aaron Herskowitz <[email-masked]>
Date: Tue, 17 Jan 95 09:59:09 -0500

I am new to procmail, but wondered if anyone has written something to  
return read receipts to all different types of mailers which may  
request them.  

I don't know much about the internal workings of many different types  
of mailers, but don't cc:Mail, MS-Mail, MIME, Unix mailers, and  
NeXTmail all have different "Return-Receipt" fields and formats that  
only a mailer of the same type that sent the message would understand  
and reply to?

If so, I would be interested in having something that would either:

a) automatically send a read receipt (or a "received by procmail"  
receipt) response to any type of mailer

    or

b) inform me that someone is requesting a read receipt and let me  
decide if I want to send them one  :-)

This might be more of a function of the actual mailer than the  
mail-delivery sub-system (procmail) though and so a filter of this  
sort probably couldn't be created via procmail.

Just a thought,
Aaron
---
Aaron Herskowitz, Director of Management Information Systems
dirigiste Investment Management Co.,Cleveland, Ohio
[email-masked]   [NeXTmail & MIME Welcomed]
Voice: 216-573-0900, Fax: 216-573-1430

---

From: "J. Daniel Smith" <[email-masked]>
Date: Tue, 17 Jan 95 13:24:49 -0500

Aaron Herskowitz ([email-masked]) writes on 17 January 1995 at 09:59:09 -0500
>[...]

Here's what I use, it tries hard *not* to send out a "got your mail"
message.

-----
PRIVTMPDIR=${MAILDIR}/tmp # private temporary files

# The entire From: or Reply-To: line
# "formail -rtzx To:" as suggested in the procmailex(1) man page
# returns only the address itself, stuff in parens or quotes is pitched
FROM_LINE=`formail -czx From:`
:1hc
^Reply-To:
FROM_LINE=|formail -czx Reply-To:
FROM=`formail -rtzx To:`

# a name that should be unique throughout the entire Internet, since
# our FQDN is unique and user names are unique within our domain.
# Could tack on some random string too. This is primarily used for
# generating X-Loop: headers 
UNIQUE_NAME=${LOGNAME}.${FQDN}

# subject lines from other vacation programs
VACA_SUBJECT="^Subject: .*(\[(ack(nowledge?ment)?|on vacation)\]|\
auto(matic)[- ]reply|away from mail|out of town|can ?not (reply|answer)|\

#####
##### an automatic reply back to people I don't correspond with on a
##### regular basis...I get too much mail
#####    - skip program mailers
#####    - skip low priority mail
#####    - prevent loops 
#####    - In-Reply-To/References: in case someone replies to
#####      something I posted to a mailing list (add Newsgroups:?)
#####    - skip local addresses
#####    - already in .friends/cache?
#####    - skip mailing lists I maintain
#####
FROM_CACHE="${PRIVTMPDIR}/${LOGNAME}_procmail_fromcache_`date '+%y%m%d'`"
:0Whci:/tmp/${LOGNAME}_procmail_fromcache.lock
* !^FROM_DAEMON
* !^Precedence: ?(bulk|list|junk)
* $!^X-Loop: ${UNIQUE_NAME}
* !^(In-Reply-To|References):
* $!${VACA_SUBJECT}
* $!^From:.*@.*${FQDN}
* !? grep -i "$FROM" $MAILDIR/.friends
* $!^TO(owner-.*|.*-request)@${FQDN}
| (touch $FROM_CACHE; chmod 600 $FROM_CACHE)
:0Ac
* !? grep -i "$FROM" $FROM_CACHE
{
  :0Whci:/tmp/${LOGNAME}_procmail_fromcache.lock
  | echo "$FROM" >> $FROM_CACHE

  :0f
  | formail -rt -I "Precedence: junk" -I "X-Loop: ${UNIQUE_NAME}" \
           -I "Subject: acknowledgement of mail sent to ${TO_LINE}" ; \

  :0bf
  | (echo "Hi!" ;\
  echo "" ;\
  echo "This is just to let you know that your message to" ;\
  echo "${TO_LINE} about ${SUBJECT}" ;\
  echo "arrived in my mailbox on ${DATE}." ;\
  echo "" ;\
  echo "If you are expecting me to reply in some manner to your email," ;\
  echo "please be patient; I'll respond appropriately as soon as possible." ;\
  echo "" ;\
  echo "Thanks," ;\
  echo "   Dan" ;\
  cat ${HOME}/.signature )

  :0
  ! -oi -t
 }
-----

   Dan
----------------------- message is author's opinion only ----------------------
J. Daniel Smith <[email-masked]>                   http://www.bristol.com/~dan
Bristol Technology Inc.	                        +1 203 438 6969, 438-5013 (FAX)
Ridgefield, Connecticut (USA)                           {info,[email-masked]
                                --------
 Von guten Maechten wunderbar geboren, erwarten wir getrost, was kommen mag.
 Gott ist mit uns am Abend und am Morgen, und ganz gewiss an jedem neuen Tag.
	- Dietrich Bonhoeffer

---

From: Andrew Cosgriff <[email-masked]>
Date: Wed, 18 Jan 1995 08:02:33 +1100

>only a mailer of the same type that sent the message would understand  

My understanding was that sendmail (or whatever MTS you use) does the 
returning of the receipt (at least from watching some MS-Mail come into our 
site)...

Of course I may be wrong...:)

Andrew.
-- 
 - Andrew J. Cosgriff -  (BH) [email-masked] (AH) [email-masked]
 UNICO Computer Systems | Email Server (BH addr.) : "send file help" as subject
The meaning of a word is what is explained by the explanation of the
meaning.        -- Ludwig Wittgenstein, "Philosophical Investigations"