Subject: Re: coredump in concon()

From: Richard Coleman <[email-masked]>
Date: Tue, 31 Jan 1995 14:51:27 -0500

> Heyla, I only just subscribed to the list and I was wondering if there
>  are any patches that haven't yet made it into procmail.  My current
>  version is 3.10 (2 Nov 94)

A lot of the zsh hackers seems to be on this mailing list.

> Mine coredumps fairly often in concon() (mailfold.c)
> ch=32, i=9
> confield.offs[] has some really extreme values in .offs[4 or 5 upwards]

What architecture is this on?

> :0 h				# Zsh mailing list
> * ^Resent-Sender: owner-zsh-list*
> ARTICLE=|sed -n 's/^X-Mailing-List: Z shell.*\*\([0-9]*\) .*$/\1/p'
> 
> :0 A
> zsh/$ARTICLE

Interesting recipe.  This might be a little neater.  I'm sure David
or someone else can improve on this.  I haven't tested the following,
so you might want to look at the $LOGFILE.

What I've done
1) drop the glob, you don't need it.
2) added a lock file.
3) made it a nested recipe

# File zsh-{list,announce} messages by article number.
:0: zsh/$LOCKEXT
* ^Resent-Sender: owner-zsh-list
{
	:0 h
	ARTICLE=|sed -n 's/^X-Mailing-List: Z shell.*\*\([0-9]*\) .*$/\1/p'

	:0
	zsh/$ARTICLE
}

Richard Coleman            pgp key (keyID 0x71FB29E1) at keyservers (or)
System Administrator       send me e-mail with subject "get pgp key"
School of Mathematics      for automatic response.
[email-masked]

---

From: [email-masked] (David W. Tamkin)
Date: Tue, 31 Jan 1995 15:17:29 -0600 (CST)

Richard Coleman answered Geoff Wing,

| > :0 h				# Zsh mailing list
| > * ^Resent-Sender: owner-zsh-list*
| > ARTICLE=|sed -n 's/^X-Mailing-List: Z shell.*\*\([0-9]*\) .*$/\1/p'
| > 
| > :0 A
| > zsh/$ARTICLE

| Interesting recipe.  This might be a little neater.  I'm sure David
| or someone else can improve on this.  I haven't tested the following,
| so you might want to look at the $LOGFILE.

All right, since Richard threw down the gantlet, and since Geoff said
he's running version 3.10, try this.  I personally don't like trailing
whitespace in my rcfiles (it's too easy not to notice), so I use brackets
to protect trailing spaces or tabs:

  :0:
  * ^Resent-Sender: owner-zsh-list
  * ^X-Mailing-List: Z shell.*\*\/[0-9]+[ ]
  zsh/$MATCH

As I understand, the lack of quotes around $MATCH in the folder name will
cause it to lose the trailing space, exactly as we want.  If not, we can
cure it this way:

  :0:
  * ^Resent-Sender: owner-zsh-list
  * ^X-Mailing-List: Z shell.*\*[0-9]+[ ]
  * ^X-Mailing-List: Z shell.*\*\/[0-9]+
  zsh/$MATCH

No braces, no seds, no forks, no compound recipes.

David W. Tamkin  Box 3284  Skokie, Illinois  60076-6284
[email-masked]    MCI Mail: 426-1818   +1 312 714 5610

---

From: Andrew Cosgriff <[email-masked]>
Date: Wed, 01 Feb 1995 10:42:58 +1100

>No braces, no seds, no forks, no compound recipes.

One last problem :) - doing this means that the "unseen" sequence doesn't get 
updated.

What'd be *really* cool would be if we could file it by the article number 
*and* update the "unseen" sequence, so ExMH can tell me I haven't read that 
article yet.

Anyone know how to do this ?

MH 6.8.3's rcvstore doesn't allow you to specify the target filename inside 
the folder, so it doesn't look immediately trivial to do...

Andrew.
-- 
 - Andrew J. Cosgriff - [email-masked] - SysAdmin, UNICO Computer Systems.
 Mail Server - "send file help" as subject, PGP Key - "send pgp key" as subject
    "It's not the bullet that kills you, it's the hole" (Laurie Anderson)